Admin channel timeouts and unresponsiveness

I would use a faster setting, it is flakey but does work on 1.2. Everything for saving config is all admin messages in 1.3 so it should be fixed for all the speeds soon.

I successfully implemented remote admin with this topology:

PC <--> Tlora 2-1-1.6 on COM38 <--> Tbeam 1.1 aka !55c55fd8


Not a bad idea.
Here are some notes to help: link
I’ll update that link if I learn more.

A big change for me that made it work initially was running this command on ALL nodes using same admin channel …

meshtastic --ch-index 1 --ch-enable

The above command assumes you installed admin channel on index 1.

1 Like

Tlora 2-1-1.6 on COM38

What is this?

I had some issues earlier today with the remote admin channel and I think this was due to not having the same channel index. However despite fixing that and getting it working between two nodes on 2.0.0, the alpha versions I have been unable to get working.

+1 to the meshtastic --ch-index 1 --ch-enable

aka Paxcounter Lora32
aka Lilygo Lora
aka the cheapest hardware you can get on amazon prime with esp32 and Lora module, no gps.

What was your working topology?

Is this alpha hardware or v2 alpha?

So updated everything set up identical admin channels on all my radios listing all the nodes just fine from the cli, but cannot admin any radio remotely. I did get some not authenticated error which I’m not sure what that could be, any ideas? Here’s the output:

Connected to radio

Requesting channel 0 info from remote node (this could take a while)
WARNING onResponseRequestChannel line:606 Channel request failed, error reason: NOT_AUTHORIZED
Error: Timed out waiting for node config

That means the channel the packet arrived on is not named ‘admin’. Can you check whether you set up the channels correctly by running meshtastic --info?

I used the webgui but when I do a --info on a connected node (serial) it doesn’t show the admin channel…strange. Guess I have to create it on the CLI instead.

yep that was it, I needed to create the admin channel via the CLI…using the webgui didn’t work.

1 Like