Meshtastic

70/5000 After I flashed this program I don't have a gps signal with other software

Hello
I bought a T-beam TTGO board (T22_V1.1-2019.1212) with the Meshtastic software pre-installed.
Everything works fine with this program, however I would like to use it with the SoftRF ogn tracker software, but after I flashed the software it can’t see the GPS. The red GPS signal LED flashes, but no satellite. I flashed the Meshtastic again, and it saw satellites.
However, I had an other board like this and that worked with SoftRF software fine. I also installed the Meshtastic firmware on it to test it. It also saw the satellites. But after I restored the previously working version of SoftRF, there has been no satellite this board since.
I also tried the ESP32-OGN-TRACKER program (https://github.com/pjalocha/esp32-ogn-tracker.git), it worked with this before but there is no satellite anyway.
So now I have 2 piece T-beam boards that only see the satellites with the Meshtastic software.
What could be the problem?

Hi and welcome to the forum.
Meshtastic changes the GPS to run in UBX mode. The other SW needs NMEA mode.
@eriktheV-king has made a small program to reset the mode for the GPS. It is described in this post

6 Likes

Hi
Thanks for the quick help.
I uploaded the sketch from the attached link and everything is fine again.
Thank you once again!!! :slight_smile:

3 Likes

My preloaded unit T-beam T22 1.1 and N6M had gps issues till I loaded the 1.1 beta firmware

@moorsb, I noticed the same behavior. I had 3 new devices powered up and outside until I was able to update them, so maybe 30 mins. I was a little concerned they weren’t working proper. Once they were updated I got a lock on 10 satelites inside of a minute.

1 Like

yes - just after we released 1.0 a kind person donated code that significantly improved GPS performance (I don’t think he reads this forum though - just github).

1 Like