1.2.4 ready for alpha testing (and it might be painful?)

Hi ya’ll,

1.2.4 of the android app, the python API and the device code is up for especially brave testers ;-). If anyone could try this and report back that would be great!

If you can access the play store it would be extra valuable if you could try installing the app from there, then see the warning about how you must upgrade firmware and then use the app to upgrade the firmware over Bluetooth. If that has problems (or you don’t want to use play store) you can get firmware from github.

Alternate place to find the app.
To update python “pip3 install --upgrade meshtastic”

First public alpha of this major release chain.


  • Unless you truly want to be an ALPHA tester, you should stay with the 1.1.x device and app releases for now
  • 1.2 nodes can’t talk to <1.2 nodes. So all nodes in your mesh must update.
  • Some security features are not yet turned on in this 1.2 release, that will take another couple of weeks
  • firmware builds are now region independent. You must use the android (in the settings tab) or python (with --set region X) tools to set the region for your radio and location. However, we try to preserve old region info, so if you are updating it will try to keep your region correctly. If we don’t know your region we guess and use USA frequencies.

Major changes:

  • Settings & channels can now be changed remotely via messages inside the mesh (not yet ready for testing by ya’ll yet - first I want to make a python testharness)
  • We now ‘piggyback’ acks on application layer replies, this substantially reduces airtime consumed
  • Multiple channels are simultaneously supported (not yet ready for testing though - please wait until I write a full wiki on the topic)
  • Lots of internal cleanup which will result in smaller/faster packets
  • We now have assigned a ‘meshtastic’ LORA sync byte for meshtastic, so the radio hardware should filter any non meshtastic packets.

First test is successful.
I installed app from Google play. It took some time for it to find my TBeam. Then there was a popup explaining i need new FW in the device. Upgraded OTA with no problem. It managed to keep the region from the previous version on the device (1.1.50).
Will continue with more TBeams later today.


Successful OTA updates.
Regional settings were kept properly.
T-beams are seeing each others.
Good gps locks.

I understand there is no encryption support yet.
I will do more testing tonight.

1 Like

Btw: to clarify encryption still works as before. But the remote settings change stuff is not yet guarded.

Temporarily, if you let someone into your mesh they can change your mesh settings - which will be fixed. Though no ui for doing this remotely, so they would need to be determined :laughing:

For now you need to really trust anyone who you are letting use your mesh.

Ok, understood, thank you.

Then I have identified a change since the previous android version (i.e. for me before 1.2.04):

I have my channel settings saved on a txt file on my phone. It contains an address in

Every time I wanted to configure a device, I would open the txt file, select the address, and a “use with Meshtastic” pop up menu would appear. It would then apply the new settings.
I am not getting this Meshtastic menu, instead the address is handled as a normal web address, in my case via Brave.
I do not know if it is related to Meshtastic not registering anymore for this, or if it is linked to my android setup.


Same experience here with Samsung S10+
Problem with the choise of channel is that the channel in the app is different from what appears on the device.
Most is 2 letters down or up from the app but in case of A to Z and it can give 4 down so will give W to Z and W to Z will give 4 up and gives you channel A to D.
So you can put different devices in the app on channel O but then on one device get M and the other on channel Q.
I hope this helps.

1 Like

On S20+, was able to download from google play, update firmware through app to 1.2.04. Can choose same channels between 2 tbeam 1.1 s . Cannot send messages, get GPS lock. Tbeams disconnect. Have flashed firmware twice with same results. US board and US selected.

1 Like

Did get GPS lock, just took a while, intermittent connection to radio, when accepting new channel had to restart app as channel page went blank. Messages never show completed sending, do show on oled screen of originator, not other board. Radios keep getting disconnected. Neve see other board in group radio part of app, only see board that is connected to phone.


Same issue here, looks like the key sharing isn’t working, can’t get the same key into multiple radios.


The link just goes to a GitHub 404 error page.

1 Like

Exciting, any chance of uploading the android app APK to github? I only see the source code.

tbeam 433 cannot see each other, cannot exchange messages. report recently sent

For the first time I was able do OTA update, but as the other people have mentioned, messages are visible only on connected radio and are not passing through LoRa to other nodes.

re: not seeing texts from other nodes
Ooops - oh yes, thanks for all those reports. If unlucky on channel assignments that could happen, fixing today!

re: URLs not sharable between apps
The URLs are encoded differently from <1.2 (by necessity - they need to support multichannel). That ‘version’ difference is encoded by the urls starting with …meshtastic.org/d instead of the old …/c. All apps and nodes must be using 1.2 or later to work together.

I got all apps and nodes on the latest version, it just pulls up the GitHub 404 page in the browser not in the meshtastic app.

1 Like

thanks - can you try rebooting your phone and then see if it will use meshtastic for meshtastic.org/d/… URLs? I’m thinking that possibly android has cached the wrong URL resolver…

1 Like

Thanks, that worked. Still not receiving/displaying messages

1 Like