Meshtastic

1.2.23 alpha released to fix remote GPIO access

This release (for alpha testers only) is mostly to fix the remote GPIO feature. That feature (though intended only for advanced users) was poorly documented and broken in the 1.2 tree. It is now fixed (I think). You’ll need device firmware >=1.2.23 and python tool >=1.2.23.

Also it is now documented.

Other changes in this release:

  • @mc-hamster improved the docs on rangetestplugin
  • The first draft of the new MQTT gateway feature code is in, but it is disabled by default (and not ready for anyone who is not me to waste their time with it ;-). This code only turns on if you have a channel which has uplink_enabled or downlink_enabled set to true.
1 Like

Noticed a small mistake in step 2 of the instructions, should read
meshtastic --ch-add gpio

I’ve been using the 1.2.23 alpha with a pair of Heltec boards for the past 2 days and it seems very stable.

I was pretending to be @geeksville

I installed Mosquitto MQTT on my Macbook,
meshtastic --set is_router true --port /dev/cu.SLAB_USBtoUART
meshtastic --set wifi_ap_mode false --set wifi_ssid ‘myhomewifi’ --set wifi_password “mypskaaaaaaa” --port /dev/cu.SLAB_USBtoUART
meshtastic --set mqtt_server 192.168.1.123 true --port /dev/cu.SLAB_USBtoUART
meshtastic --ch-set uplink_enabled true --port /dev/cu.SLAB_USBtoUART

joined a channel with another node

% meshtastic --info --port /dev/cu.SLAB_USBtoUART
Connected to radio

My info: { “myNodeNum”: 99999999, “hasGps”: true, “numBands”: 13, “firmwareVersion”: “1.2.23”, “rebootCount”: 420, “messageTimeoutMsec”: 300000, “minAppVersion”: 20200, “maxChannels”: 8 }

Nodes in mesh:
Preferences: { “lsSecs”: 300, “wifiSsid”: “myhomewifi”, “wifiPassword”: “mypskaaaaaaa”, “isRouter”: true, “mqttServer”: “192.168.1.123” }
Channels:
PRIMARY psk=secret { “modemConfig”: “8675309”, “psk”: “qwertyxxxxxxx”, “name”: “LoaLoa”, “uplinkEnabled”: true }

Trying to connect to the local mqtt server on the mac from the mac is fine but sending messages between nodes didnt send any traffic to the mac mqtt server. Im not complaining, just excited I got as far as specifying the mqttServer from looking at protbuf. For all I know my test message went to test.mosquitto.org or mqtt.meshtastic.org

Super excited to see this being worked on! Is the device a broker and the mac would be a subscriber?