Trying to set up MQTT support

I have set up a Hel-Tek board to connect to my home Wifi. That part seems to be working OK. I am now trying to set up the MQTT Bridge on this board.
In the Channel settings have used Ch1 and set it to Secondary, the pre-Shared Key shows four periods, the Name is set to Texas, Uplink and Downlink are enabled.
In the Module Config MQTT Settings, MQTT is enabled, Server Address is, username is meshdev, password shows to be populated with 10 or so periods. Encryption is enabled, JSON is enabled, Map Reporting is enabled.
So far, I have no indication that my packets are being passed out to the MQTT broker and I have not seen any other nodes or messages show up on the Nodes, or Messages windows. I have posted a few Greetings from Joinerville, TX. messages from the node I am using as the MQTT Gateway as well as from another node that has the Texas Channel configured.
How can I tell if my packets are being sent out over the Internet to the MQTT broker?
I do not see my node’s position being reported on the MeshMap (
I have looked at several messages and documents on how to set up the MQTT support but so far I can’t seem to find the right combination of settings to get it to work. I would like to connect the Texas channel and then perhaps a sub-channel for my local town here in Texas, or perhaps the County.
Any assistance would be most appreciated!


Hi Keith
Have you tried pinging the heltec node from another computer.
Start with that.
From a terminal window
ping ipaddress
if you get a reply that confirms heltec is connected to your wifi

Yes, the Ping works to the Heltec board and I can log into the Heltec from my desktop computer using it’s IP Address so it is connected to my Local network via WiFi. My concern is if I have all the parameters in the Heltec set up correctly for it to access the Meshtastic MQTT broker or server. I left the Zero Channel set as Primary with with its default settings. I configured channel one as a secondary channel and enabled the MQTT uplink and downlink on that channel. I also set the MQTT channel to the default Meshtastic channel parameters but set the topic, I believe as mesh/US/TX. I expected that to uplink and downlink packets to and from the Internet, through my router, to my Heltec board and then out onto the mesh network on channel one, to any local nodes using the same channel one settings. So far I have not seen any activity on channel one. I have sent a few messages on channel one in hopes that they would be routed out to the Internet, to the Meshtastic MQTT broker and then to any other users on the mesh/US/TX channel. Maybe I am not understanding the parameters correctly to send and receive traffic to and from the MQTT broker or server. I was wondering if there was some easy way to test or see if I had everything set up correctly. I assume that once the packets are passing through the Meshtastic MQTT broker that my node should show up on the meshmap when I view it.
Thanks for the suggestion. I will continue to poke at it from this end!

Hi Keith
ok thats good that you have connection so as you suggest issue is with MQTT settings.
You have the uplink and downlink enabled on the channel you want so that leaves the MQTT config.
Ill have a poke around and see if I can find anything to help on settings
(p.s. i have mine set up on a local mosquitto broker)

Have a look halfway down here is shows the settings
not sure how current it is but worth a look

Hey Brett,

Thanks for the information!

I have looked at that document and tried to follow it as far as possible.

The configuration screens I am seeing accessing my HelTec via a web browser are similar but not the same as those shown on this site document.

I am wondering if my Verizon Router might be killing me. My Internet access is via a Verizon Cellular Router so that may be an issue for me.

I am also not 100% sure about the MQTT channel settings.

I was hoping to access the “Texas” channel if there actually is such a thing using –


Username: meshdev

Root Topic: mesh/US/TX

Channel Name: Texas


Looking into the HelTec V3 which I am trying to use as a MQTT Gateway on my mesh, I see these screens in my browser.

In the Module Config screen, I have the MQTT page set as shown.

I have the Root Topic set for msh/US/TX

Under Channels I have the first channel as PRIMARY with something in the pre-Shared Key field. (It shows up as Dots)
The Name field is empty, assuming this is the default for the Primary Channel.

Uplink and Downlink are both Enabled.

I want to add two additional Channels.
One for Texas and one for Houston.
On the channel config page for the Texas channel, I have it set as Secondary. The pre-Shared Key is AQ== I believe but it also just shows up as Dots.
The Name Field is set to Texas
UpLink and DownLink are both Enabled.

The Third Channel is Named Houston, (as in Houston Texas). I have it set as Secondary with the same Pre-shared key and again Uplink and Downlink are both Enabled.

I am obviously missing something or have something misconfigured as I can not send nor receive any messages to the Texas or the Houston MQTT subject.

I assume the Primary Channel needs to have it’s MQTT Uplink and Downlink disabled so I do not send and receive to the Primary Long/Fast channel, but I may be mistaken. It just isn’t making a lot of sense to me.

My Internet access here at home is through a Verizon, Cellular Router which has a dynamic IP address and perhaps the Verizon Router and Servers are blocking my traffic to the Meshtastic MQTT server. But it seems like the whole Meshtastic system is based on mobile devices supplying the connection to the MQTT broker so the Verizon Router may not be the issue.

I’m looking for suggestions or things I can try to get this MQTT gateway working.

Henderson, TX.

Hi Keith
From what I can see everything looks good.
The only question is around the broker/mesh topic you are publishing to
does it need encryption
does it need json
does it need tls
I had a quick google but couldnt find anything about the broker you are trying to connect to

good luck

I’ll keep tinkering with it.
It’s bound to be something in my configuration that isn’t right!


-.- -. … --.

Hi keith
Have you seen this yet

Yes, I believe I have but I am going to print it out and go through my gateway node again.


-.- -. … --.

1 Like