T-Echo GPS Not Trurning Off

I have two T-Echos running 2.3.13, which shows GPS concordance when I disable GPS in settings and not allow app location services on the phones.

One worked as expected, and I did not save the configuration before defaulting it to test. The only changes from default are long and short names and GPS disabled.

I have cleared the position log on both Echos and power cycled several times.

GPS shows up on an Android phone and not an iPhone; the coordinates are correct on the Andriod.

What am I missing?

I also have, in my T-echo ( df972), the “GPS mode” DISABLED in the Radio Configuration → Position menu. However the GPS seems not to be off because I can see my own updated real-time location on the map in the meshtastic app. From this [llink (Configuration Tips | Meshtastic) it seems like the GPS of the Android phone which I am using with the T-echo is being used by default for my setup, and seems to be related to the choice of primary chanel. Very odd and complicated it would seem, unless once again, I have failed to read and/or understand the instructions…

I have changed channel 0 to an encrypted channel and primary to channel 1; both are set GPS poison off.

T-Echo 1 is back not showing GPS, T-Echo is still showing GPS. I backed up config 1 and uploaded to 2, no change.

I was going to do a drive by of a friends house that has a node. Now neither Echo is updating past nodes in the list since I made the channel change this morning.

I have fixed my problem on my Android app by going to the three dot menu - radio configuration - channels - press on the box showing e.g. “0 LongFast” , this opens more options, select the entry under “Position” and change this to “DISABLED” - send. I think that then stops the phone GPS from providing the GPS coords even if the GPS mode is set to DISABLED in the menu you reach via the in the three dot - radio configuration - position menu … maybe that will solve the problem ?

I did the drive by with 0 encrypted and 1 LongFast, did not show up in the nodes of by friends RAK.

Switch back to 0 LongFast and 1 encrypted, back to original problem.

Verified 0 LongFast is DISABLED.

For the #meshtastic T-echo techo lilygo , in order to switch off GPS tracking, it did / does not suffice to set (a) under Radio Configuration → Position the “GPS mode” to DISABLED and also (b) under Channels each channel “Position” to DISABLED. For my Android 14 app I had ALSO (c) to set under Android settings → Location → Meshtastic the Location Permission to “Ask” or “Don’t allow”

All the settings are set as stated in last reply.

Not sure why, but it is now not broadcasting GPS.