Newb trying to get t-beams to function

I just purchased my first 2 t-beam units v1.1 from AliExpress.(Could possibly be version 1.0 from a website I read) I flashed both of the units with meshtastic, I still can’t get them to function correctly. In the app sometimes I can get them to pair up with both my phones but, mostly they won’t. (I 2 have pixel 4 android phones). I’m able to set the region, they just will not connect any farther than that. No sending messages or anything. From What I can see, these are the current firmware’s to use:





Those are the only firmware I should flash to both of the units, correct? (Just 1 on both units I guess) Not sure if the app is really buggy or it’s just me and the wrong firmware. I really don’t know what else to do to get them working. I’ve been trying different things for the past couple of days and, I don’t see any errors when I flash the firmware. Here is a description of the item:

LILYGO® TTGO T-Beam V1.1 LoRa ESP32 With OLED 433/868/915/923Mhz (Purchased the 915mhz ones) Development Module Wireless GPS NEO-6M SMA 18650 Battery Holder

You want the tbeam firmware if you have tbeams

1 Like

Tried these ones:

firmware-tbeam- (Doesn’t work)

firmware-tbeam0.7- (Very buggy screen glitches out)

firmware-tbeam-s3-core- (Also didn’t work)

I’m gonna try to go through the tlora ones, and see if anything works.

I tried the Meshtastic windows program and it’s saying “looks like a RAK 11200” was detected. lol. I think the app is as confused as I am.

The first one is what you want, tlora is a different board

1 Like

as garth said, this is the correct firmware for your Tbeam. the one that has “0.7” in the title is for an old version of the Tbeam hardware that’s no longer for sale, and Tlora is a different board.

In the Meshtastic Flasher program you can select tbeam from the “Device” dropdown and ignore the “RAK 11200” message.

Delete the bluetooth pairings from the phones, make sure the above firmware is loaded and give it another shot.

meshtastic is a work in progress done entirely by volunteers so there are definitely things that aren’t worrking 100% yet but don’t get discouraged because the stuff that is implemented works well, and there seems to be pretty active development on the project

1 Like

Unfortunately, I still can’t get them to connect with that firmware. I tried it on my Windows 11 PC and my MacBook. It looked like when I flashed on the mac, it sorta started to function like normal. (ill add the pictures)

I think I’ll start reading up on it more as well. After that i’ll give it another go. Either that or I might just hold off on it and give it a try maybe once a month to see if it will work. That makes sense it might not be ready if its volunteers doing it. I can’t blame them to be able to fix everything that fast. Still looks like a cool project and, hopefully I’ll be able to get it working. Appreciate the help.

This is probably because you use the Android app from the Play Store. For device firmware 1.3.42 you need to join the testing program on the Play Store, or download via F-Droid (Meshtastic F-Droid Repo), or using an APK from here: Release Meshtastic Android 1.3.42 alpha · meshtastic/Meshtastic-Android · GitHub

1 Like

It finally works now!! I just updated the app and everything setup with no issues! (I took screenshots of the setup as well). I’m surprised that’s all it was. I figured I screwed up something on the boards. Anyways, I installed the latest beta firmware and that was it. Runs perfect. It does mention about ‘firmware update required’ but I can’t see that in the app.

I manually flashed it using this command: .\device-install.bat -p COM3 -f

Hopefully this post can help someone else trying to set it up and is having a lot of issues. I’m going to setup the other t-beam to my 2nd phone and see how it goes. Thanks for the help again!