Meshtastic timed out

I am constantly not able to use the Meshtastic cli to communicate with my TBeam radio. I recently used the chrome web flasher and successfully flashed both of my radios with the latest version. (see screenshot)

I am trying to use the CLI now to set up the gpio channel using the python meshtastic package and every time I get this exception…

% meshtastic --info         
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.9/bin/meshtastic", line 8, in <module>
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 933, in main
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 709, in common
    client = meshtastic.serial_interface.SerialInterface(args.port, debugOut=logfile, noProto=args.noproto)
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 57, in __init__
    StreamInterface.__init__(self, debugOut=debugOut, noProto=noProto, connectNow=connectNow)
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 50, in __init__
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 74, in connect
  File "/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages/meshtastic/", line 402, in _waitConnected
    raise Exception("Timed out waiting for connection completion")
Exception: Timed out waiting for connection completion

I am able to call chip_id and grab that information. This is the output from that…

% chip_id  v4.1
Found 6 serial ports
Serial port /dev/cu.wchusbserial51850163561
Detecting chip type... Unsupported detection protocol, switching and trying again...
Detecting chip type... ESP32
Chip is ESP32-D0WDQ6-V3 (revision 3)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: 58:bf:25:05:5d:18
Uploading stub...
Running stub...
Stub running...
Warning: ESP32 has no Chip ID. Reading MAC instead.
MAC: 58:bf:25:05:5d:18
Hard resetting via RTS pin...

Things I’ve already tried:

  1. upgrading pip3 (version: pip 23.0.1)
  2. reinstalling meshtastic (version: 1.2.95)
  3. reinstalling esptool (version: 4.1)
  4. re flashing the radio (version:
  5. restarting my Mac (Ventura 13.1)
  6. reinstalling the Silicon Labs driver (version: 6.0.2)

I also can see the radio id is connected under my “Hardware → USB device tree”

Hopefully there is something obvious I am doing wrong here. I have been able to connect before and get or set values through the CLI.

Thanks for any help!!

Ventura already has the driver built-in, you do not need to install this. Try removing.

So before I tried removing it, I was able to get the command “meshtastic --info” to work 1 time on an old firmware: 1.2.50

I’ve since then tried removing it with no luck.

Firmware 1.2 is end of life. It would be good to switch back to firmware 2.0.20. Then you have to upgrade the CLI with pip3 install --upgrade meshtastic.

I have upgraded the firmware on this radio, this time using the CLI for flashing instead of chrome. I’ve also deleted the Silicon driver. Still no luck getting a meshtastic command to communicate with any of my Tbeams and I have 4 of them.

I also tried setting up a virtual environment and running meshtastic commands from there, but this had the same behavior.

What is the CLI version right now (meshtastic --version)? You mentioned it to be 1.2.95, which does not work with 2.0 firmware. Therefore, you have to upgrade it with pip3 install --upgrade meshtastic.

I did a force reinstall of meshtastic to get it to upgrade to 2.0.12. This was after my first post but before deleting the silicon drivers. So the command still is not working with the latest meshtastic version. Which maybe that’s why it worked at least once with that old firmware version on the Tbeam.

Currently my pip meshtastic version is 2.0.12 and my firmware on the Tbeam is

Did you make sure to close the tab of the web installer and any other program that might be accessing the port? If yes, I’m not sure what goes wrong.

Although it is very new and not yet finished, maybe you have better luck with the C# CLI.

I have not tried this yet, that would make sense though! I’ll give this a try later tonight.

So I finally found my problem…

I had accidentally installed another version of python over a year ago that was at 3.9 and trying to run an old version of meshtastic when I’d run the command in terminal. So it was calling a version of meshtastic that was 1.2.95.

I just didn’t realize I had a second version of python installed so when I’d run pip install, it would install the latest meshtatic to the python3.11 bin. Really dumb of me but glad I found this. Won’t be making this mistake again!

Thanks for your help @GUVWAF @Crichton

1 Like