How to configure buzzer notification using a rak4630?

Forgive me if this might seem like a very simple question with a very obvious answer. I get nervous when I’m trying something new. I have destroyed 4 devices because i have wanted to try do something ive never done before.

My question is how to safely configure a buzzer to notify me whenever i get a new message?

I bought several meshtastic starter kits (19007 base board with the rak4630). I also bought buzzers rak18001 for several of these kits. I have watched the YouTube video that goes into what you can do with external notification. In the video it says he put the gpio to 21.

When i go to the website it doesn’t say anything about putting the gpio number to 21. It mentions something about pwm buzzer. I’m not sure what a pwm buzzer is and i dont see anywhere in the settings where i can choose the option for a pwm buzzer.

So far i have installed the latest firmware to the rak4630 and installed the buzzer on slot C. What do i do next to make the buzzer go off whenever i get a new incoming message?

Here are what my setting look like so far:

I have the same question, did you ever get this figured out?

Me too. Also, is it a different pin when the baseboard is the 19003

21 is correct for a 19007, I think the 19003 is 9

1 Like

9 doesn’t seem to be working on the 19003. It’s on Slot D, so I suspect the pin needed is IO6.

Sorry, but reading the replies is not enough for me to get the buzzer working on a 19007 board. Using the Apple app.


I’m assuming you’re all talking about the RAK18001 buzzer? I bought a bunch and they’re all very quiet. I’ve been looking to make them louder.

That being said, the pin assignments are a nightmare to figure out unless you’ve got a copy of Microsoft Excel handy. It’s literally an Excel worksheet.

Here’s the link to the RAK IO Pin Mapper:

I’ve only had luck with using the RAK18001 in Slot C of the RAK19007 base board with the RAK4631 core. That being said the Pin number for that configuration is 21.

Make sure to configure and enable External Notifications and make sure that the Use PWM option is ticked. Make sure to UNSET the Buzzer GPIO Pin in the External Notification settings for the PWM buzzer. In the Device config is where you set the PWM Buzzer Pin. Why for god’s sake did they separate them who knows.

Good luck gentlemen.

1 Like