Configuring bluetooth fixed pin

Hey!

Just got my hands on T-Beam. I don’t have my display soldered just yet and trying to test the device out. I got the device working with the bluetooth but it’s on fixed password and it’s little too simple for me. I exported the config and changed the fixed pin and when uploading it I get an error “Aborting due to: Node.writeConfig() missing 1 required positional argument: ‘config_name’” Tried with default config and after editing the regional stuff on the app but got the same error on both times.

1 Like

The CLI commands are working, I don’t think the YAML has been tested

Oh right. What would be the right command for it? :thinking:

Thanks. I’m still confused about how the commands would work. Maybe it would be good idea to add examples because the --ble stuff on the help section got me confused.

Got my hands on soldering iron way faster than I thought at first. It’s been more than 10years since I’ve touched soldering iron and first time I’ve done that specific work. Took me little while but got the screen working :ok_hand:

Sorry, can you clarify what solved this problem? Or what is on the Bluetooth config doc page to help solve this?
I see the same error and can’t decipher what to do. Thanks

This worked for me:

remove the user_pref: label and unindent the labels below it.