Configuring Channel Via Python API

I flashed it with esphome-flasher, which I’m guessing is the issue according to Wiki How-to-use-“Meshtastic-Web”-over-WiFi.

I just created new project in, created ‘data’ folder, pasted the three files at Mashtastic-web Git page into this data folder. Then I clicked ‘Build filesystem image’, followed by ‘Upload Filesystem Image’. Both times there was SUCCESS message in terminal.

Now I get this on meshtastic.local/static page, but still cannot upload files;


Thanks for trying to flash it both in esphome flasher and from within platform io. That’s what I would have asked you to try. :slight_smile:

I have not seen this problem before. Looks like either the filesystem partitioning didn’t work or the flash chip on your board is not what it was made out to be.

Has anyone else seen this? There should be no reason to have just ~50kb of total space on a newly flashed device.

I just tried a third T-Beam V1.1, same issue.

I tried to use install script that comes with firmware zip file, no success;

I’m grasping at straws here. If anyone has other ideas, please chime in.

Could you open your device in a web browser and point to /json/report ? I’m looking for something that looks like this:


If you could, could you also post your debug log starting from the reboot? There may be something about the SPIFFS in there.

I’m still playing with, this is what I see for this board;


This leads me to believe board is okay, it may be just how I flashed it? These boards originally came with SoftRF preloaded, when I flashed them with esphome-flasher does it erase everything prior to installing Meshtastic?

I’m still trying to figure out how to use, doesn’t work on windows. I enabled Windows Subsystem for Linux and installed Ubuntu terminal but still doesn’t work…cannot install pip for some reason

I have to figure out how to post debug log, I’ll post it once I find out how to do this.

Ah ha! Thanks for sharing about SoftRF.

I just went through the SoftRF source and found that they use the minimal spiffs partition scheme. This gets us in the right direction.

This means that we need to figure out how to change the partition table of your board.

I think you mentioned you were able to get platform io running. Could you try running 'erase flash" and then re-upload the firmware? I don’t know if this will update the partition table, but it’s worth a shot.


Also, since you’re in platform io, to get the serial / debug console:



I erased flash using, then I loaded Meshtastic again using esphome-flasher tool on windows. After setting wifi credentials, I can connect to meshtastic.local/static but there is no change in amount of memory;


I’m still working on how to run this serial/debug console in When I click on that little ‘cord end’ icon you indicated I get a terminal open with this;

This does not look right does it? I don’t really know what I’m doing in, have to play with this a bit more…

Helo. I have the same bug. The difference is that i’m using ttgo lora 32 not the t-beam version. On my device fabric was installed pax counter, then i installed my sondy go software. After that i was installed myshtastic 0.9.7 using espflasher, afther that i updated via bluetooth from app on my phone to version 1.1.32.

Trying 3 diffrent browsers and always get the same msg “write aborted”.

Mayby that give you some thoughts.
I will look further for solutions.

I had the same problem with two Tbeams, but managed to erase the flash through the command line allowing me to upload a fresh build and get a proper amount of space.

When in the root directory for the project I used:
pio run --target erase --environment tbeam

One of my tbeams (sx1262 & M8N) now runs perfectly, has uploaded he files and the webpage works well. The other (6M) is still misbehaving somewhat. It uploads the two smaller files without issue, but when trying to upload the app.js.gz file, it gets stuck in a loop with the following debug code.

00:02:23 [WebServerThread] File Length 4163
[HTTPS:E] Multipart incomplete
00:02:23 [WebServerThread] File Length 4163
[HTTPS:E] Multipart incomplete
00:02:23 [WebServerThread] File Length 4163
[HTTPS:E] Multipart incomplete
00:02:23 [WebServerThread] File Length 4163
[HTTPS:E] Multipart incomplete
00:02:23 [WebServerThread] File Length 4163

A further erase and reflash got the second tbeam working as well :slight_smile:

1 Like

I was able to resolve this by flashing boards with Thanks

1 Like

Hello to all,

I´m new in meshtestic and just got the 3x tbeam a few days ago. After getting started and several things run good I can´t get the webUI running. As described above it is not possible to upload the three files and I´m quite sure that is due to the limited space.
My tbeams also had the SoftRF previous installed.

I don´t know how to erase the hole storage on the ESP32.

I use Win10 and the flashing via “” doesn´t work.
I get the follwing result:

C:\Users\admin\Desktop\firmware-1.1.42> -f firmware-tbeam-EU865_1.1.42.bin
File “C:\Users\joche\Desktop\firmware-1.1.42\”, line 6
show_help() {
SyntaxError: invalid syntax

It would be highly apprechiated, if you could help my.

Thanks a lot

I suggest you follow these instructions first, then try again uploading the three webUI files.

Thanks for your fast reply. I already tried this and up to step “6.” step everything worked fine.
But the actually flash process doesn´t work and I get the failure messeage I posted in the above question.
What did I do wrong?

Fast, yes, useful, non so much :grin:

I’ve misread your post. The problem is you’re trying to use a bash script on Windows.

Perhaps the easiest way around this is to open in a text editor and look for the commands, then run those in the same sequence.

1 Like

So that means the script is only possible on linux or mac os?

It’s possible on all systems with a compatible shell or interpreter. I’ve never tried it, but apparently on Windows you could use an interpreter called “git bash”.

Thanks again for our support!
It just work by flashing manually step by step: --baud 921600 erase_flash --baud 921600 write_flash 0x1000 system-info.bin --baud 921600 write_flash 0x00390000 spiffs-*.bin --baud 921600 write_flash 0x10000 firmware-tbeam-EU865-1.1.42.bin

Even the three files for the webUI are available now.


But, I´ve already the next issue:
I can connect to the hotspot and open the “”, but after that I get a button “Connect to Meshtastic device” in the browser.
After clicking it says “device as been configured”. Nothing else.

How can I get to the WebUI to configure the parameters and read/send messages?

Best regards

1 Like

You need to erase all three files on static page and upload updated ones. I believe there are updated ones on meshtastic-web github page.

Here we go!!! It works. After flashing with command line, there were three files in /static/, BUT these files are not the one with can be found on meshtastic-web github page.

I uploaded the three files from meshtastic-web github AND I deleted the original .html, which was available after flashing.

Everything is fine now!!! :slight_smile: :slight_smile:

1000 Thanks for your extreme fast and good support.

By the way, where are you guys from? I´m located in germany stuttgart.

1 Like