T-Echos Reliability

T-Echos are quite expensive but would be good for hiking. So I have two but they do not work. One is definitely dud and would not even get a fix on SoftRF. The second works well on SoftRF and gets a stable gps fix. But never functions on meshtastic.
I wanted to poll the forum - are T-Echos generally reliable? There are a few comments on the Forum about them - nothing obviously suggesting they are often faulty. But I just wanted to check. Is it worth me buying another two units as I have just been unlucky? Thanks!

1 Like

A few weeks ago I updated the battery voltage reading on the RAK4631 and did a similar fix for the T-Echo since they are related (and @geeksville asked me to). I do not have a T-Echo so that fix has to my knowledge not been tested/verified.
For the Rak4631 I have it running for a few days and then it will go to deepsleep and not wake up. I suspect some instability in the voltage sensing. There may be similar problems with the T-Echo. I don’t know.
If you want a stable board I would go for the TBeam. That seems to be running good.
I assume that during the autumn the problems with the Rak board will be fixed.

Hi Thanks for your response. Yes my T-Echos also go into sleeping mode from which they need usb power to recover - this still occurs on 1.2.45. And although there is no gps lock in fact they do measure the distance to my T-Beams quite well and they mesh although I have not tried to send messages (I have no android phone!).
As you say the T-Beam does work well - it’s just quite heavy in the waterproof case from Peli Products (the case is very good otherwise). For info my T-Echo battery level reads 4.14V fully charged and ~3.2V at nearly empty.

Interesting! I’m just searching through the forums because my T-Beam shows 3.42V as 0%. Not trying to hijack, though…

I ordered one and I cannot get it to work, as detailed in another thread here. I am trying to resolve / find the issue with lilygo but communication via Aliexpress and uploading videos is quite slow.
I wonder if there are several iterations or versions of T-echos that have been sold (other with or without the BME sensor) and that this means there isn’t one firmware that works for all, or if these are duds.

I ordered and received 2 T-Echos.
One reflashed nicely, and seems to work. The other ‘downs’ a 5v usb supply, and cannot be reflashed or recharged. The installed SoftRF seems to work.
I’ve had a couple of emails with Zhang at LilyGo about this, but the line seems to have ‘gone dead’. He had me measure a couple of points to check for short circuit - and no.
Has anyone else had this trouble, and maybe found a solution?

Hi Thanks for this. I am afraid I can’t help with your issue - mine have never been un-reflashable or un-chargeable.
I was late in telling LilyGo that my T-Echos were not working because initially I thought it was just me making a mistake. So when I messaged them I was outside the complaint time. They asked for evidence of what was wrong. I replied but no response from them now. It would be good to know how many T-Echos are working because now three of us have seen +50% failure rates. I still hope they are fixable.
I can get to view their status using Arduino IDE serial monitor but the output means little to me. I wonder if there is a pointer to the solution in this output?

1 Like

I’ve also stopped hearing from Lilygo despite a couple followups.

Trying to fix my T-Echo as well; it worked ok for a couple of days on 1.2.42 and then refused to respond. Looks like it went into deep sleep and just…isn’t waking up.

No device is detected when plugged in; no response on any of the buttons. If the battery is connected the red charging light goes on, with the battery disconnected and USB-C connected the red light flashes rapidly. Checking the battery with a multimeter I’m seeing about 3.0V; trying to do a full charge now with an external charger to see if that changes anything.

After that I’m guessing it’ll be down to JTAG. Very disappointed - my T-Beams work just fine but the T-Echo is a big step forward in design.

I am testing a change to the low voltage detection right now.
I have added a counter that will need 3 battery low readings in a row before it goes to sleep. As it is now in the released code it will go to sleep on the first low reading. I started with a full 18650 battery and will let it run until it goes to sleep. It will probably be some time during the next weekend.
The NRF52 boards are still fairly new to Meshtastic and there may be more bugs to be found and fixed.
I am using the RAK4631 board which is also NRF52 and I don’t have a T-Echo.

By the way, the low voltage cutoff is set to 3.2 V. I think it will work for you after a recharge but I don’t know why it is not detected when plugged in.

There is a bug report on the ‘going to sleep issue’

Awesome! I still can’t get any response after charging the battery to full - and the red LED flashes only briefly with USB-C plugged in so it does appear to see it’s charged… JTAG adapter ordered.

I wouldn’t be too concerned about the T-Echos just yet. All 3 of mine seem to run softRF no problem. I think any meshtastic issues are purely software bugs at this point.

2 of them are loaded up with an older version of meshtastic and seem to work ok, except the GPS is little buggy when it is plugged into external power. 1 of them (w/ the Baro) has only run SoftRF.

image image

Thanks for the positive thought. One of my T-echos give a No Fix response on SoftRF but the other seems to work. So I am going to keep them and hope their problems are fixable!

Mine works with SoftRF, but with none of the meshtastic firmware versions, neither from the Meshtastic GitHub nor from LilyGo.
I have the version without BME - has anyone managed to get Meshtastic installed on this one?
If I install meshtastic and then go back to SoftRF, SoftRF remembers the previous settings - I would expect those to be wiped, but I am stuck as to how to proceed.

Short update on what fixed the T-echo problems I was reporting:
I ordered a Segger J-link which arrived today and followed the instructions here to erase the chip and then burn a new version of the bootloader.
I then installed 1.2.46.dce2fe4 alpha and the T-echo is now finally working!


Hi @Nanovitruvius this is great! Do you have a link to the J-link you used? I am in the UK so I was hoping to find a local supplier but I need to make sure I get something equivalent to yours. Thanks a lot for this work to fix the t-echo.

1 Like

I was going to buy the T-Echo because it seemed more power-efficient on paper with better location capabilities but now I am just going to order 2 T-Beams.

I suppose the T-Echo needs a lot of polishing before it’s ready for practical usage.

1 Like

Hi @feh123 I bought a used J-link Base that can do JTAG and SWD (which is what you need as far as I remember).
It seems there are both original and copies available of the hardware online, at least judging by the massive price differences - can’t comment as to functionality or any other aspects of this though.

@kokroo - Having bought 6 T-beams in various flavours, 2 RAK4631 and the T-Echo, I very much favour the RAK4631 over the rest. The quality is better than the others, and the power efficiency and size are on par with the T-Echo. In addition you can solar charge if you want, and expand the board in the future with sensors etc.

I’d assume the T-Echos shipping now come with an updated bootloader so the problem I had may or may not be fixed.

Thanks @Nanovitruvius the link is great.

Does anyone else with T-Echos want to comment about the latest status of the reliability of these devices?