Meshtastic

Serial port baud rate is changing!

Mentioning now so I don’t forget: the changes I’m merging tonight will include a change of the debug serial console from 115200 bps to 921600 bps. This won’t make a difference if you are not doing stuff with the serial console, but if you are - that’s why your devices just stopped talking to you ;-).

2 Likes

I have been unable to connect to the serial debug on my device using OSX.
Is debug disabled if an OLED is installed?

What toolchain would you recommend for this new baud rate on OSX, it appears that Arduino IDE does not include this speed in the drop down menu.

I have two Heltec devices, both with a display of course. Using the ESPHomeFlasher debug mode I got some debug messages, so I think its enabled whether the display is installed or not.

As a toolchain you probably will use VScode and install the platformIO extension. See in Wiki

1 Like

I’ve tried this on a couple of PCs and two different T-Beams but have been unable to connect with PuTTY.

When I press open it just plays the Windows ‘Bong’ sound and that’s the end of it.

I have got the correct COM port from Device manager (I had to install the driver on one of my PCs) and I have successfully put the latest firmware on to the devices (proving the cable and everything else), but I can’t get anything from PuTTY.

I am using baud 921600.

Thanks

Simon

I successfully connected using ‘Termite 3.4’ (an RS232 tool).

1 Like

I think I have been able to get it to work, but I have not tried very recently. Check to see if your Serial|Flow control settings on PuTTY are set to use None or XON/XOFF. Hardware flow control (RTS/CTS, DSR/DTR) is repurposed for other things on most ESP32/ESP8266 boards, including the T-Beam.

Just checked. It works for me.

COM3, 921600/8-N-1; XON/XOFF. Opening the port resets the device (due to a driver glitch).

With Debian Linux:

apt-get install screen
screen /dev/ttyUSB0 921600

e.g.

17:29:29 219 [RadioIf] (bw=125, sf=7, cr=4/5) packet symLen=1 ms, payloadSize=60, time 136 ms
17:29:29 219 [RadioIf] Lora RX (id=0x1abd0cad Fr0xf0 To0xff, WantAck0, HopLim3 Ch0x81 encrypted rxSNR=9.75)
17:29:29 219 [RadioIf] AirTime - Packet received : 136ms
17:29:29 219 [Router] Add packet record (id=0x1abd0cad Fr0xf0 To0xff, WantAck0, HopLim3 Ch0x81 encrypted rxSNR=9.75)
17:29:29 219 [Router] Using channel 0 (hash 0x81)
17:29:29 219 [Router] Expanding short PSK #1
17:29:29 219 [Router] Installing AES128 key!
17:29:29 219 [Router] decoded message (id=0x1abd0cad Fr0xf0 To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 rxtime=1631122169 rxSNR=9.75)
17:29:29 219 [Router] handleReceived (id=0x1abd0cad Fr0xf0 To0xff, WantAck0, HopLim3 Ch0x0 Portnum=4 rxtime=1631122169 rxSNR=9.75)
17:29:29 219 [Router] Plugin nodeinfo wantsPacket=1
17:29:29 219 [Router] Received nodeinfo from=0xf266e0f0, id=0x1abd0cad, portnum=4, payloadlen=40
17:29:29 219 [Router] old user !f266e0f0/Unknown e0f0/?F0
17:29:29 219 [Router] updating changed=0 user !f266e0f0/Unknown e0f0/?F0
17:29:29 219 [Router] Plugin nodeinfo considered

Comment from the code:

 * we override this to notice when we've received a protobuf over the serial
 * stream.  Then we shunt off debug serial output.