New Plugin - RangeTestPlugin

Good morning!

It depends on what you’re testing. If you’re testing mesh performance, then you’d want to have them all running at the same time. If you’re testing point to point performance, then you want just two.

If there’s no GPS chip, meshtastic gets the location from the phone but the range test plugin gets it from the GPS chip directly. I should add that to the documentation.

1 Like

Awesome thanks man… I did a impractical range test via a drone with a Tbeam straped to it. I set it to med and sender 30, ill go back and look cause im probably missing something but it only updated location every every 6 mins but sent a message every 30, I asume the advanced setting in the app override whatever sender is default to, if thats how it works. Also is there away i çould have it report elevation too? I brought it up to 1300 feet just for fun but it was anticlimactic.


"

Did you have the sender or receiver on the drone?

Re: Altitude…

Consider it done, it’s just a line of code.

Please open a feature request so I can tag the PR with your request.

I mean, literally, it’s done. I just need a ticket to reference :slight_smile:

image

At the time i had the drone as sender. Im going to have it receiving when the weather clears up.

Is this what you needed me to do ? Report Elevation while in range test, · Issue #758 · meshtastic/Meshtastic-device · GitHub

Thanks for that:) ill be reporting back when it clears up… ill have 3 in the air in different areas at some point too.

Thanks. I’ll submit it tonight.

1 Like

Having problems.

Two TBEAMS running 1.2.20 Alpha. Both have GPS lock.

Sender
{ “rangeTestPluginEnabled”: true, “rangeTestPluginSender”: 60 }
Free : 386038 Bytes

Receiver
{ “rangeTestPluginEnabled”: true, “rangeTestPluginSave”: true }
Free : 386289 Bytes

I can send texts back and forth when the plugin is disabled, so they’re talking, but no CSV is being generated on the receiver after ~30 mins. Both OLEDs seem to be counting up maybe? I see “seq 20” on both at this point.

Note that I didn’t capitalize the commands, this is just how they’re written in the --info output.

I considered backing down to v1.1.x, but then the meshtastic commands fail with “you need newer firmware.”

Well ok… I unplugged everybody for a few hours, came back to try again and the csv just appeared and started growing. No idea what happened.

Were the devices restarted after the initial configuration where enabled and save were turned on? The settings don’t kick in until a restart.

A quick scan of the docs showed that restarting is not mentioned as a requirement for using the plugin. When I pull together documentation for the main site I’ll make sure to include that step! But if you have time to add it so I don’t forget, let me know!

1 Like

I swear I unplugged them. But the receiver unit does have a battery installed, so it’s possible it never shut down completely? But it was showing the “seq nn” string, so at least some of the config was working, just no file. Odd.

Feature request: Double the size of the “seq nn” font. Hard to read when the receiver it on the dashboard. Larger font would allow for quick glances rather than squinty “is that 36 or 88??”

By golly, you’re correct. I’ve updated it. Thanks!

1 Like

Unplugging will switch it to the battery. Most boards have a reset button, that works great.

Hi - just tried out the plugin today on two tbeams running 1.2.28 - worked very nicely. With no special antennas I managed 17km. This is further than I have managed when sending messages - often only 8km (using 1.1.50 and the iOS app). Should there be some reason for this? Or is this just an accident of where I went today and line of sight issues? Incidentally the spreadsheet recorded measurement was in metres - can I make this km? I did wonder if I could set the send rate to say 15 mins and actually show the lat/lon on my receiver OLED - so acting like a beacon from which I could see where the sender was while they were moving? I guess this depends a lot on how long the gps needs for a lock to get an accurate position? Great Plugin - thanks.

hello, i want to test RangeTestPlugin.
I am using T-beam v1.1 and the rev. is 1.2.45
I can’t find the rangetest.csv and the membary can’t change. it keeps 47690 Bytes
I have tried some methods, but not work.

Have some idea to me? thanks for help

Some tbeams arrive with a strange memory configuration that messes with the range test plugin, try flashing the spiffs firmware file first and then the regular file and the range test plugging should work as expected when configured

I can’t use esphome to flashing the spiffs firmware file and I can’t use esptool.py to erase and re-flash the firmware:


Maybe the batch file works better? I am sort of out of ideas if that does not work since I use linux for firmware flashing because I have also had issues with esptool on windows.