New cross platform firmware flashing tool

We have just released a new GUI application called meshtastic-flasher that will hopefully make the process of setting up your meshtastic devices much easier.

Please test and post any issues to GitHub!

12 Likes

This is supernice!
I notice it needs a very late meshtastic installed. It first crashed when starting but a

pip install --upgrade meshtastic

solved that problem.
Does it do a full install or just an update?
(thinking of the scripts in the zip file)
Edit: Found the advanced menu by pushing A: it can do both install and update

1 Like

amazing! being able to flash firmware using single-executable binaries is a game changer.

2 Likes

Fantastic! Thank you very much - I’ve been struggling with doing this manually. This is so simple.

2 Likes

Awesome, thanks for testing!

Hello all,

I have tried to flash the LILYGO TTGO ESP32, SoftRF but every time Meshtastic Flasher shows this:
User does not want to flash
I did everything, restart the Windows, but it’s still the same problem!?

Reza

Did you select no when it asked if you had meshtastic > 1.2 on the device?

Yes, I did select NO, as it has only SoftRF.
I have 2 x devices and I tried both, after I select the FLASH, it doesn’t matter I click YES or NO to Flash, in both cases Meshtastic Flasher shows:
Flash was clicked
Update only is not checked
User does not want to flash

@garth - I tried both ways and got the same message.

I also tried the advanced options with both checked, both unchecked, top checked, then bottom checked. All with the same ‘User does not want to flash’

Also, it is more of a box in a box - there is no checkmark. This is not a criticism, I just don’t know if there may be both ways to fill the box and I am just seeing one.

I did exactly as you did and the result was the same as you said!!

Update to the newest version of the flasher tool, we fixed this bug yesterday.

1 Like

I had to install the silabs drivers from their website before the flashing tool would work. Consider adding this to the instructions.