Multible MQTT topics

Is it possible to subscribe to multible topics

what to subscribe to
msh/EU_868/DK
msh/DK

and how to do it from web gui

No, but you can use different channel names.

I built my own mqtt broker and configured it according to the instructions on the official website, but I did not receive any messages from mesh

Can you share the method of configuring mqtt and successfully sending messages? Thank you very much

this is my mosquitto config for my raspberry pi mqtt server…

# Place your local configuration in /etc/mosquitto/conf.d/
#
# A full description of the configuration file is at
# /usr/share/doc/mosquitto/examples/mosquitto.conf.example
per_listener_settings true

pid_file /run/mosquitto/mosquitto.pid

persistence true
persistence_location /var/lib/mosquitto/

log_dest file /var/log/mosquitto/mosquitto.log

include_dir /etc/mosquitto/conf.d

allow_anonymous false
listener 1883
password_file /etc/mosquitto/passwd

connection bridge-01
address mqtt.meshtastic.org:1883

topic # out 0
topic # in 0

remote_username meshdev
remote_password large4cats

it simply pulls everything, i believe there are ways to modify that ‘topic’ setting to perhaps do multiple topics but i havent had time to investigate

1 Like

Thanks first. May I ask about your meshtatic firmware version?

on Heltec WiFi LoRa 32 V3
(v 2.2.23)

mqtt on

Module config > MQQT enable + proxy to client
Radio settings > Lora > Ignore MQTT = off
Channels > Primary MQTT > on

MQTT - default settings - if gone
mqtt.meshtastic.org
meshdev
large4cats
msh/EU_868

other changes

Config > Radioconfig > Device Settings >Rebroadcast Mode > ALL
Config > Radioconfig > Device Settings > Node Info Broadcast Interval > 3600 = hour (10800)360

Config > Radioconfig > posision > Broadcast Interval > 3600 = hour
Config > Radioconfig > posision > GPS Update Interval > 3600 = hour
Config > Radioconfig > LoRa > Hop Limit > 5
Config > Module Config > Telemetry > Query Interval > 3600 = hour
Config > Module Config > Telemetry > Update Interval > 3600 = hour

Config > Module Config > Neighbor Info Settings > Enabled > ON
Config > Module Config > Update Interval > 3600 = hour

1 Like

im using firmware 2.2.24

1 Like

I’m using firmware 2.2.23. The configuration of meshtatic is almost the same,but
fail 。I have built my own mqtt broker, and my requirement is to send text messages and location messages within the message through the gateway to this broker, and receive messages through the mqtt.fx client. My usage method is as follows:
mashtastic side:
Channels: Channel Settings:Role=PRIMARY
Uplink Enabled
Downlink Enabled
Radio Config: Position Settings:Enable Smart Position=Enabled
GPS Enabled
WiFi Config: The configuration is normal and I can access the
internet
Module Config: MQTT Settings:Enabled
MQTT Server Address= agri.weexis.com:1883
MQTT Username=aaaaa
MQTT Password=bbbbb
Encryption Enabled=disable
JSON Enabled=Enabled
Root topic=msh/EU_433
Proxy to Client Enabled=disable
mqtt.fx side: subscribe topic=msh/EU_433
I sent a message, but did not receive any content or location information on mqtt.fx.I don’t know where the problem is。Help me

I built a broker using Mosquito, and after monitoring, I did not find any messages coming from Meshtatic

Without a proper user/pass to agri.weexis.com I cannot check if that MQTT broker is working correctly. Try to connect with MQTT Explorer and see what’s going on.

I can obtain the data now. I have two topics, msh/2/json/d/! Da5e4eb0 and msh/2/e/d/! Da5e4eb0
When I send text messages, it’s almost always msh/2/e/d/! Da5e4eb0 hit, rarely msh/2/json/d/! Da5e4eb0 hit, it is difficult to obtain JSON data

1 Like