Meshtastic

iOS and TTGO bluetooth troubleshooting [closed]

Can anyone with an iPhone and a TTGO/Tbeam try and see if the smartphone sees the device on bluetooth?
Thanks

I could try with an Ipad

1 Like

11 Pro Max (iOS 13) does not show the tbeam v1 in the list of nearby devices.

1 Like

I tested with an iPad 4 and an iPhone 8 and the TTGO doesn’t show up.
If anyone knows why please tell

No luck with iPhone XR and iPad 6 here

1 Like

I can’t remember but I think it’s a Known Issue. It’s mentioned somewhere here.

@Anelito here you go Alpha tester thread (no new tests needed at the moment) 🙂

1 Like

I can try tonight with this app https://apps.apple.com/us/app/lightblue/id557428110

ok thanks everyone problem solved, I had to switch to another plugin offering more control over bluetooth

The standard iOS bluetooth pairing UI doesn’t show BLE devices. It will show in “nRF connect” - which is an excellent tool because it also lets you manually test BLE transactions to the service we have on the device.

1 Like

Same here. Don’t see device using BLE scanner apps from my iPhone.
Not sure if it’s device software or hardware issue.
iOS 14

I was able to get it visible using nRF Connect. What is strange is that I could connect but it only prompted for a pin one time, after that. even after resetting the connection data it would not. Which makes me think there are some other BLE protocol level things that are going wrong with the pairing. I tested this with a 11 Pro

I tried with an iPhone 7 (iOS 13.6) and nRF Connect - identified the tbeam okay (0.8.2) but would not connect - error connection timed out unexpectedly. No pin request at all.