HELP: Platform Problems updating to 1.3.17

Hi,

Apologies - I couldn’t categorise this myself as it occurs across all client platforms.

The iOS App on my iPhone automatically updated over the weekend which persuaded me to start updating my devices (2x TTGO T-Beams V1.1, 1x Lora32) devices to the new firmware (1.3.17). The new app doesn’t connect with the old firmware as you know.

Flashed the firmware this afternoon on one T-Beam using on MacOS terminal and PythonCLI - device booted and is happily chirping away with 10 satellites locked on indoors.

However, the long and the short of my problems over the past few hours:

  • After flashing, as I have to flash not upgrade, I normally update the devices settings through the Python CLI. I now get the error message running any command in the terminal e.g. meshtastic --info.

Exception: This device needs a newer python client, run ‘pip install --upgrade meshtastic’.For more information see Using the python API during the 1.2 transition - Python API - Meshtastic

  • Running the command ‘pip install --upgrade meshtastic’ to update the meshtastic CLI generates the following error message (Note that replacing pip with pip3 resulted in the same error message):

WARNING: There was an error checking the latest version of pip.

I’m running pip 3.10 on an iMac running 10.13.6 High Sierra. Neither the meshtastic flasher or meshtastic runtime work either, never have.

At this point, I go back to my phones:

  • The iOS app can’t update the Region and Channel defaulting back to United States. Device currently showing as unset. The gmail link to share my channel only works when paired with the android phone.

  • The Android app is at 1.2.67 and hasn’t updated to 1.3 so won’t connect to the device.

  • Neither my Chromebook nor Mac can access through the serial interface and client.meshtastic.org with both getting stuck at "Reading device configuration’ for circa 5 minutes. Eventually an error message comes up to say: The requested file or directory could not be found. Better luck next time.

Whilst I can roll back the firmware to 1.2.64 and use the Python CLI and Android App (1.2.67) for settings, I can’t see how to roll back the iOS app (edit: worked this out now - back on 1.2.53).

All advice appreciated - happy to add any more info where I can.

Andy

Please refer to 1.3 Enthusiast | Meshtastic for answers to most of your questions.

Specifically:

  • The iOS test flight has 2 releases now. 1.2.53 and 1.3.17 - please make sure you got the right one
  • You have to sideload the Android App from github. Obviously the alpha version is not on playstore.
  • CLI doesn’t work with 1.3 yet. The preview flasher will only flash the device, the settings dialogue will not work.
1 Like

Thanks @caveman99 much appreciated.

That link must be the one page I hadn’t already found, so great to see everything is consistent - and apologies for not having found already!

I’m a bit paranoid about my old iMac not being upto the job as it won’t install a lot of python related applications due to many being built in macOS11 onward.

Good news is that I can confirm that 1.3.17 did load on my t-beams without complaint and immediately locked on to GPS. The iOS app also looked great - and I’d migrate were the features enabled.

For now, I’m sticking with 1.2.64 to learn and develop.

Thanks again.