Meshtastic

Error Trying To Join Channel

I have two devices. I couldn’t get an order off aliexpress(non-technical reasons) so I ordered through Banggood instead. They sent me two slightly different devices for some reason. So I’ve got the following:

TTGO T22_V07 20180711 this has two small white switches and one slightly larger black switch. USB power to the left of those switches.

TTGO T22_V1.1 20191212 this has 3 small white switches with power to the left of the switches.

The T22_V1.1 I flashed firmware-tbeam-US-0.7.11.bin with no problem at all. This was connected to my phone without issue and the app OTA updated 0.8.1 with no error or issue. Paired via BT to Android 1 phone just fine. I believe this device is fine and working properly. It gets GPS and places it on the map properly.

The T22_V07 is a different story. The information regarding what to flash is kind of confusing. I first attempted to flash the same firmware. This flashed fine but resulted in a boot loop. I did the chip_id check which seemed to halt the boot loop. I then flashed firmware-tbeam0.7-US-0.7.11.bin which seems to have gone correctly. This paired to Android 2 phone just fine and seems to run properly. It gets GPS and places location on the map. However it will not OTA to 0.8.1. Pressing the update button seems to do nothing at all.

I tried manually setting the channel to the same channel on both devices. The devices don’t see each other. I then tried sharing the channel link and they still don’t see each other.

I then tried connecting T22_V07 to my PC and using putty to check the output running through the process. No errors while re-flashing firmware-tbeam0.7-US-0.7.11.bin No errors while pairing to Android 2. This time I went straight to the pre-existing channel link to setup the channel. This is when I see the error.

[E][vfs_api.cpp:135] remove(): /db.proto does not exists or is directory
Warning: Can’t remove old pref file

I assume this means the channel isn’t getting changed properly which is why these devices can’t see each other. That’s kind of where I’m stuck currently. Did I fail to flash the correct firmware here or is there a deeper problem?

Thanks in advance for any assistance or guidance.

1 Like

This is harmless - it just indicates the device has never been to deep sleep yet.

Hopefully others will chime in to help with the other questions - if not I’ll happily help in a couple of days.

1 Like

Good to know nothing is broken. Thanks for that much information at least!

I guess that leaves figuring out why the two devices don’t both show up together. I’m not seeing any other errors via putty serial connection. The two device look like they’re in the same channel but they don’t show each other on the map or share chat.