Consistency issues with the Mesh

The reason for turning up the broadcast and turning off smart was to get to know the GPS and how it acts. I had all the values defaulted and had some problems so I started over and changed things as needed. A faster broadcast of the GPS was needed. If I was running these in real world I’d keep the smart position on. I’m not to concerned with their range as much as the GPS and the overall performance.

Next time I’m out with these I’m going to turn everything default and send messages to get them to populate. We’ll see if that doesn’t clear up the problem.

For 1.3 using the range testing plugin (set a sender or two and don’t worry about the save yet as there is no way to get the file) and telemetry to create mesh activity without affecting the core functionality has been working well for me. Turning up position updates without movement is weird in testing. We did find today that when smart position is off empty position packets get sent sometimes, which could clear nodes from the map.

1 Like

@garth you mentioned “empty position packets get sent sometimes”, which sounds like a bug to me, and a bug which has the potential to mess up things pretty bad.

  1. it can cause nodes to disappear as you wrote.
  2. it increases the mesh utilisation without actually saying anything, which will then cause packet loss.

Turn off the smart broadcast and crank up the GPS update interval and you are have introduced confusing behavior. Smart position by its nature requires that the GPS have a position, using an interval does not.

smart broadcast does work with the interval together. No need to disable smart broadcast.

With 1.3 and range test and telemetry working nicely, if you want to create a lot of mesh activity with any device you can turn up the device telemetry updates to 15 seconds and use the range test from an ESP32 to create messages. This is a much more reliable way to test and revert then messing with position features.

1 Like