Bluetooth Pairing Problems

The app was just updated yesterday to .6.5 - you can try updating.

I am also having similar issues on one of my phones (And I think I am just going to put this is my signature, like many I see on XDADevelopers) but not the other, and it doesn’t depend on which device I use

2ea TTGO T-Beams, v1.0
HTC 10, Android 7.0 OEM <— BT problems on TTGO, but no noted problems with other BT devices)
HTC U12+ Android 9.0 OEM

btw - vader. re the BT problems on the TTGO

Someone else reported this and I think that our install instructions might be missing some important ‘settings’ reformatting the command is not doing. If you are comfortable running the platform IO build tools could you try the following and tell me if it fixed things for you?

(you’ll need to edit platformio.ini to make sure the region is set correctly for whichever country you are in)
pio run --upload-port /dev/ttyUSB0 -t upload -t monitor

Got it - I cloned the repo before dinner (and drinks) today and tomorrow Ill work on getting my PIO install to talk to my TTGO’s

Over dinner I had a buddy install the android app (.6.5) on his phone (Galaxy S8 OEM) and he was able to pair with a T-Beam on .6.4 and we were able to exchange a couple messages at times with about 30-60 second latency between the Android apps, however the timestamp read 4:00pm 7/8 times

Hi Just to say I updated to 0.6.5 (still running 0.6.4 on both radios; TTGO T-Beams) and that worked much better. I can see the two radios on my app and by Putty both radios are connected to the phone. The app map shows them accurately positioned in my house.
However I cannot send texts - I get the error not connected to radio. On the radio page it shows connected to radio but sleeping. So it seems to work and then thinks the radio has gone to sleep. Does this make sense?

Hmm - where does it print this message?

The radios will go to sleep (to save battery - they are still talking over lora, just bluetooth is sleeping) but they wake up periodically and check if the phone has anything new to send.

Hi the message appears only on the app. Nothing in Putty serial that I noticed anyway. On the far right tab where you see which radios the app is picking up. The message appears just above the radio names.
Also if I go into bluetooth settings on my phone or tablet I see the two radios under my paired list. However unlike all my other bluetooth paired devices which immediately say connecting when I press the icon, nothing happens when I press the radio icons.

hmm - interesting. I’ll take a look tonight when I look at the other app bug report. thanks! Is your github username feh123?

Hi, thanks, yes my GitHub username is feh123.

ok @vaderj’s log had what I think I need. feh123 - what is your phone model (so I can find it in the google reports)?

Hi I have a Sony Z1 (model C6903) running Android 5.1.1 - I am not sure how to get a log file like @vaderj. I hit the report bug on the app this morning as it is still showing the same error message. It sees both radios but does not connect. Thanks.

I had the same problem on my Nexus6. When I did the last uprgade of the app I went into system->apps->Meshtastic. I first did a ‘force stop’ and then went into the storage where I pushed ‘clean storage’ and ‘clean cache’.
Now I could do a fresh start and did a new BT pairing. After this everything has worked.
Maybe just uninstalling an app can leave data behind that a new install will use?

Hi thanks for the info. I tried the reset process but I still get this error connected to radio but it is sleeping. So I get them to pair in settings bluetooth but although paired apparently something is wrong and then I get the sleep message. To me it seems that my phone BT is just not pairing correctly and the app therefore is unable to work correctly. The two radios do see each other but not via the app. Appreciate the help.

I also confirmed a similar problem.


  1. Once the radio is connected to a phone and the Bluetooth on the radio is disconnected, the new phone will not connect.
  2. When I pairing the radio with Bluetooth on the new phone, the app won’t connect. and not recognized.

[Test content]

  1. Delete app data and cache
  2. Reinstalling app
  3. Reflash firmware

[Test environment]

  • 1st Meshtastic firmware : ttgo-lora32-v1-JP-0.64
  • 2nd Meshtastic firmware : ttgo-lora32-v1-JP-0.64
  • APP ver : 0.6.6
  • 1st phone Android ver : 5.11
  • 2nd phone Android ver : 6.0

Thanks for the report! Can you re-enable analytics (so I can get a crash report from Google), then force quit the app (to make sure analytics starts).

Then try this sequence - preferably waiting at least 10 secs between clicks (makes it easier for me to read the logs). Then press report bug (so the Google thing sends a report).

Then I’ll make a GitHub bug and attach the log. What is your GitHub username (so I can cc you there)?

1 Like

I don’t use GitHub because I am an end user, but I followed the procedure and reported bug.

There is nothing stopping you from creating an account if you wish - certainly not a requirement but, personally, I can’t think of a downside of having a github account.

1 Like

This problem has been resolved. Thanks to @geeksville and community members.
Some versions and firmware between the problem and resolution environments are not verified.

[Problem environment]

  • Meshtastic firmware : ttgo-lora32-v1-JP-0.68
  • APP ver : 0.7.2

[Resolution environment]

  • Meshtastic firmware : ttgo-lora32-v1-JP-0.76
  • APP ver : 0.7.78

1 Like

Im also having the same or similar issue. Under Bluetooth devices on my phone, it shows the device is paired. But it will not show up in the app. I was able to get the t-beam to work with an old phone laying around, but not the phone i use daily which is newer. When it comes to this type of electronic stuff, i know very little so i wasn’t able to figure out the f droid download to try a different method than google play. Ive uninstalled and installed the app several times and every. Any help will be greatly appreciated. But you will have to talk to me like im a 5 year old. Haha. Thank you

I had the same issue with an Android 10 phone. Scanning and pairing with the Android bluetooth settings worked but not in Meshtastic. Until I activated the bluetooth scanning AND location App permission (Settings → Location). The latter seems also important for meshtastic bluetooth connection.

It is required for Samsung devices on android < 12