Meshtastic

Android APP build error

Hello Meshtastics,
I am new to the forum but I want to dive into your code!

I followed the instructions from here:

  • added a Map Token to gradle.properties
    -I had the error:Invalid VCS root mapping error and fixed it by deleting the vcs.xml file located in the .idea folder in project folder

But I still get errors on building, could anyone please help me
:
<ij_msg_gr>Gradle import errors<ij_msg_gr><ij_nav>/home/x/StudioProjects/Meshtastic-Android/app/build.gradle<ij_nav>project ‘:app’: Unable to build Kotlin project configurationDetails: org.gradle.api.internal.tasks.DefaultTaskContainer$TaskCreationException: Could not create task ‘:app:minifyReleaseWithR8’.Caused by: org.gradle.api.internal.provider.MissingValueException: Cannot query the value of this provider because it has no value available.

FAILURE: Build failed with an exception.

  • What went wrong:
    Could not resolve all dependencies for configuration ‘:app:debugRuntimeClasspath’.
    Could not create task ‘:app:minifyReleaseWithR8’.
    Cannot query the value of this provider because it has no value available.

hmm - are you using android studio 4.1.2 or later?

yes, Android Studio 4.1.2
the setup is on Manjaro Linux inside a Virtual Box Machine.

hmm - I’m not sure - I haven’t seen this error before. Dear other android devs any ideas?

But to be clear - you shouldn’t have to change the project gradle.properties (it has other important things). You want to add the mapbox token to your user gradle.properties

... put that token in your user gradle.properties.
~/development/meshtastic/MeshUtil$ cat ~/.gradle/gradle.properties
MAPBOX_DOWNLOADS_TOKEN=sk.yourtokenherexxx

ooh - I just googled the error message and I bet this is the cause and fix (install sdk version 29):

Thx you, installing sdk 29 with SDK Manager fixed it, and build was successful!
:star_struck:

1 Like