Meshtastic

1.2.17 webserver help

Meshtastic-web is not serving anything but a button up in the root. /Static works fine. The doc suggests that firmware includes the -web files. Resorting to uploading them manually via option 3 still just gives the button in root How to use "Meshtastic Web" over WiFi · meshtastic/Meshtastic-device Wiki · GitHub
Looks like -web has not been updated since Feb 18. Can we expect future releases to include the -web files? Will -web get attention?

Also, the soft-ap mode turns off at sleep and does not wake back up with a button press. Must do reset to get working again.

1 Like

In the past, I had to delete the original .html file for the page to update.
Update: I tried uploading the web page from here:

0.1.7
I deleted the .html file. All pages showed something, except for settings, which was blank.
The python script syntax for --setstr wifi_ssid and --setstr wifi_password appear to have changed as they gave me an error:
meshtastic --set wifi_ap_mode true --setstr wifi_ssid meshtastic_d061 --setstr wifi_password 12345678 --set position_broadcast_secs 60 --set wait_bluetooth_secs 28800 --info
usage: meshtastic.exe [-h] [–port PORT] [–host HOST] [–seriallog SERIALLOG] [–info] [–nodes] [–qr]
[–set SET SET] [–seturl SETURL] [–ch-index CH_INDEX] [–ch-add CH_ADD] [–ch-del]
[–ch-enable] [–ch-disable] [–ch-set CH_SET CH_SET] [–ch-longslow] [–ch-shortfast]
[–set-owner SET_OWNER] [–set-ham SET_HAM] [–dest DEST] [–sendtext SENDTEXT] [–sendping]
[–reboot] [–reply] [–gpio-wrb GPIO_WRB GPIO_WRB] [–gpio-rd GPIO_RD]
[–gpio-watch GPIO_WATCH] [–no-time] [–setalt SETALT] [–setlat SETLAT] [–setlon SETLON]
[–debug] [–test] [–ble BLE] [–noproto] [–setchan] [–set-router] [–unset-router]
[–version]
meshtastic.exe: error: unrecognized arguments: --setstr wifi_ssid meshtastic_d061 --setstr wifi_password 12345678
Interesting that it didn’t take a long time to boot when I held in the middle button while pressing reset to enable the web server, like it normally does the first time. I upgraded using the cell phone because my windows usb firmware update script seems to be broken, so maybe it kept the old encryption keys and didn’t have to generate new ones.

Could you point to which doc says that the -web files are included? That would be incorrect. It’s not yet included.

Some future version, yes. It’s up to @crossan007 and @sachaw. Alas, I don’t have the timeline. It’s worked on when someone has a moment.

The soft-ap should work just like the rest of the device. That may could you open a bug on this and I’ll take a look next time I’m at my computer.

Thanks!

1 Like

How do I start using it?

You will need the Meshtastic Device firmware built with the Web files. This includes any version of the official Meshtastic Device firmware version 1.0.xx (TODO: TBD) or newer.

If “TODO: TBD” means that it’s not included then in my opinion the whole sentence should be removed.

Deleting the html file worked for me too but like DylanHoen, the settings and wifi pages do not work.

Once we have a working -web, I’ll send in a bug for the soft-ap if it continues to die.

1 Like

@Havealoha
Most up-to-date client is GitHub - sachaw/meshtastic-client only issue is that I haven’t got it building to a single file, it does however work. If you want to contribute, it’s built on Next.js so there’s plenty of help out there.

2 Likes

I deleted the “How do I start using it?” section. That was written back when the web interface was just a simple button and we didn’t have the web interface as it is now. I see how this would have caused confusion. Sorry about that.

When that document was first written, it was mostly the “Development” section to describe the end points for creation of a web interface. All the other sections were added as Charles and Sacha started contributing to the project.

Thanks for pointing it out!

2 Likes